Author Topic: problem uploading pics  (Read 9822 times)

0 Members and 1 Guest are viewing this topic.

Offline hilltopgrange

  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
  • No Personal Text Set by User
Re: problem uploading pics
« Reply #15 on: January 15, 2012, 05:03:05 pm »
Bingo! I coverted them to png and then back to jpg and it worked.
Thanks for the help
Russell

you can close this now

Offline Wolvenar

  • Senior Moderator
  • Hero Member
  • *******
  • Posts: 1474
  • Karma: +40/-0
  • Mr. Murphys pawn
Re: problem uploading pics
« Reply #16 on: January 22, 2012, 04:59:38 am »
After some investigation into this, I and others on the IRC found that certain camera insert exif data improperly.
The forum software searches for a number of things such as embedded text in incorrect places, to ensure security   and prevent a broad range of troubles that may be caused by invalid/improperly formatted pictures.

One such thing it looks for is text hiding within an image.
This has been used for nefarious purposes in the past, causing legal problems for a number very popular web sites.
In the above case I think that filter was what flagged the images since the exif data was incorrectly formatted, creating the error.

Re compressing the file or changing its format as posted earlier should fix the problem. Removing the exif data does not, as the data in question is not seen as correct exif data by more programs.

Trying to make power from alternative energy any which way I can.
Just to abuse what I make. (and run this site)