Author Topic: 8010 based 5kw chinese sinewave mosfet inverter board  (Read 160 times)

0 Members and 1 Guest are viewing this topic.

Offline Pete

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +18/-0
  • Mount Barrow Tasmania
8010 based 5kw chinese sinewave mosfet inverter board
« on: July 27, 2021, 12:44:22 am »
I recently bought one of those 8010 based inverter boards, it has everything on it all that is needed is to add a transformer and a few bits and presto an inverter is built.
My problem is that I accidentally killed the board. I connected it up to two small batteries with some jumper leads and smoke came from the leads. Yep not enough light on the bench, old eyes and reversed the polarity of the board.
So now all I get when I power it up the right way is a LED telling me that power is there.
The 8010 board has a LED but it does not light up.
I checked the MOSFETs and they appear fine, fortunately my tiny hookup leads seemed to act as current limiters.
Just wondering if anyone has a circuit of one of these chinese pure sinewave inverters.
It would make fixing it much easier if one were available.
Of course when a manufacturer doesn't even have the confidence to put their name on a board one wonders if they bother to do a circuit diagram.
My inverter is a 24 volt 5000 watt board from Ebay.
Thanks
Pete

Offline lighthunter

  • Sr. Member
  • ****
  • Posts: 265
  • Karma: +11/-0
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #1 on: July 31, 2021, 12:50:45 pm »
Hi Pete! no worries, these are about the easiest board there is to repair. Especially if the Fets are still good. There is an EGS002 board on it with a socket. Id recommend just replacing it. I got 5 for $30. Individually they can be had for $8.00 when you get the new one find a magnifyer glass and make sure the jumpers are set to your liking. Frequency 50/60 dead time etc, just copy jumper settings from your old board. I will see if i can send manual.

Then make sure fets and caps are good, you already did.

Next there is a tiny 24 to 12v 3 pin buck regulator board near the edge. You will need to make sure it works. The pins should be labeled. Vout, gnd, vin. 

I would remove the egs002 board, apply power to board through a fuse or small wire and then verify 12v, if thats good and the tiny relay clicks and green light turns on then all you have left is plug in the new egs002 board and away you go. If tiny relay doesnt work, then the housekeeping chip got hurt, its an LM324 quad comparator i think, two options, replace it or just tie your on/off circuit to the tiny relay coil (observe polarity, there is a diode across it. You can get 12v to power it from the tiny converter.  If the tiny 12v converter is hurt you could just get a new one of those too or your own 12v supply. If you wanted to fix the egs002 board it could be done but not likely worth it. Pretty much just replace the driver ics and 8010. If you think the FETs are perfect yet id be really careful about using/repairing the egs002. A wounded egs002 could wipe out those fets quickly. As cheap as those 002 boards are it just makes sense to have a few on hand.   

Those boards have virtually no labels on em so maybe grab a sharpie or black marker of your flavor and write +24 on the heat sink Gnd etc..   I can see how that could happen the way they are labeled.  The 5500w is fairly accurate as well. I hurt one by letting two grid ties go at it with 5.8kw of incoming power, so maybe keep it to 4500 to be safe. They are better than PJ when it comes to holding the voltage down, if i remember i had it set to 240 v and i think it only rose to 244.

I just reread your post and it is possible the only thing wrong with yours is the lm324 chip. You can remove it and just power the tiny relay on and you might be running. Again, use care by removing caps and supply with resistor or some trick to protect fets id hate to see you loose those now when they are worth more than all the rest of the bits.

Good luck! I believe youll have it running in no time!
Health Warning: May contain traces of nut!
LH

Offline Pete

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +18/-0
  • Mount Barrow Tasmania
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #2 on: July 31, 2021, 06:01:50 pm »
Thanks a lot LH.
I have been tangled up with other jobs around home but so far have replaced the 5 volt regulator and the LM324.
Fortunately I had those in my parts boxes.
I also have a couple of spare 8010 boards so will try changing that too.
The 8010 board that is on the inverter board has two rows of pins, but checking them they seem to be paralleled up.
So hoping the normal single row board will work.
I have not seen any other 8010 boards on ebay with two rows of pins yet. Anyway as they are just paralleled I guess that it is just for solidity that they did that.
Thanks for the tips,
Pete

Offline lighthunter

  • Sr. Member
  • ****
  • Posts: 265
  • Karma: +11/-0
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #3 on: July 31, 2021, 06:24:48 pm »
Hi Pete!

Careful, im pretty sure thats a 12v regulator, if you put a 5 in there the Fets need more voltage to turn fully on and it just may work with a lot of heat.

I know you want a print of whole board, i do not have. Aside from the 324 and two transistor switches and 12v regulator there isnt isnt much else to go wrong with the board that wouldnt be visible. Just follow your nose and look it over with a magnifier and power up with provisions of limiting current and it will be that easy.

Heres a few photos of the 002 manual.
(Yes i agree, the 2 rows of pins are just for rigidity.) I realize now you have the 24fet board, you better check the fet drivers somehow too. Those 24 Fets would be $50 to replace here, so worth protecting. Maybe popping caps out and feed power with a resistor would be safest until you know the gate signals look healthy.
Health Warning: May contain traces of nut!
LH

Offline Pete

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +18/-0
  • Mount Barrow Tasmania
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #4 on: July 31, 2021, 10:06:51 pm »
Thanks again LH.
The 5 volt regulator I changed, as far as I could see sent 5 volts to the 8010 board, it was definitely a 7805 regulator.
There seems to be 12 volts there on the board, the LED lights up when I power it up.
With a bit of luck I will get back to it tomorrow and reconnect the trannie etc.
Hopefully replacing the Op amp will have done the trick
Cheers
Pete

Offline lighthunter

  • Sr. Member
  • ****
  • Posts: 265
  • Karma: +11/-0
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #5 on: August 01, 2021, 05:43:48 am »
Your right Pete, theres a tiny version of it next to the 002, sorry, i was thinking of the larger regulator.
Health Warning: May contain traces of nut!
LH

Offline noneyabussiness

  • Full Member
  • ***
  • Posts: 129
  • Karma: +4/-0
  • I think it works....
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #6 on: August 01, 2021, 05:05:24 pm »
https://www.anotherpower.com/board/index.php?topic=1116.15

make sure you do this mod as Oz describes on first post... makes all the difference with " tight " transformers like toroidals...

Offline Pete

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +18/-0
  • Mount Barrow Tasmania
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #7 on: August 01, 2021, 05:26:56 pm »
Thanks Noneya, I will read more what Oz said about it. Seems that they tried to be too clever for our own good.
Should not be too hard to remove the 393 chip.
From what I have seen looking at the 8010 board things are pretty tight but I will see when I get a chance to look at it again.
Thanks to both LH and Noneya,
It is great to have advice on these things. Too much smoke at times gets to me. Since I added the capacitor bank to my batteries the PowerJack is behaving well. The Oz article makes me wonder if PJ have gone overboard with short circuit protection too.
If it blows again I will  just replace the boards with the 8010 boards.
Pete

Offline Pete

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +18/-0
  • Mount Barrow Tasmania
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #8 on: August 02, 2021, 12:57:08 am »
Just an update.
So I pulled the LM324 and replaced it. Today I got around to working on it again.
I powered it up but no go other than the Power LED lighting up.
Then I decided to measure the LM324 voltages. First I measured the supply and it was fine 12 volts on the V+ and V- pins.
While measuring the voltages on the comparitors I accidentally shorted the pins on pin 1 and 2, well the inverter powered up.
The LED on the 8010 board came on and the transformer hummed very quietly.
So i plugged in a load and the output came up and the light lit up.
But after about 5 seconds it shuts down. I have to short pin 2 to pin 1 on the LM324 to get it to start.
Fortunately I had put in a socket for the chip so I pulled the LM324 out and the inverter runs fine.
I am guessing that the OP amp controls things like Over and Under voltage and over current so will have to spend a bit more time sorting out what component is causing the problem.
At least I know that the inverter goes and even the original 8010 board works fine.
So that is the update
thanks
Pete

Offline lighthunter

  • Sr. Member
  • ****
  • Posts: 265
  • Karma: +11/-0
Re: 8010 based 5kw chinese sinewave mosfet inverter board
« Reply #9 on: August 02, 2021, 08:14:48 am »
Great work Pete! If you have other ways to handle over and under volts etc, you may not need that stuff. The schematic of the 002 board is worth having a look for the voltage feedback, that connection is necessar to control the throttle. It should come through the little transformer and over to the 002 board.

The 8010 has its own protection for AC voltage too high or too low and it will shut the inverter down if they are not ok. The LED on the 002 board should blink a code to tell you what ails it.

Health Warning: May contain traces of nut!
LH