Author Topic: Webcontrol 8 reboot problem solved.  (Read 2405 times)

0 Members and 1 Guest are viewing this topic.

Offline Wolvenar

  • Senior Moderator
  • Hero Member
  • *******
  • Posts: 1466
  • Karma: +40/-0
  • Mr. Murphys pawn
Webcontrol 8 reboot problem solved.
« on: February 06, 2015, 12:04:28 am »
A little over a week ago I was having difficulty with a webcontrol rebooting at seemingly random times.
I have this webcontrol monitoring temperatures and trends to predict when our hydronic wood boiler needed wood.
When conditions are met it will send an email to the text gateway which would text my cell. The problem was it was sending these to soon and to often when it really didn’t need wood.

I had done some changing and additional temp sensors were added so I attributed this problem initially to those changes or my PLC additions.

I lucked out and caught it at the right time to figure out it was rebooting, and sending those texts for wood as a result. Not the initial bug I was looking for, as I thought it was something wrong in my PLC.
Any time it would reboot I would get a wood needed text.

All things considered this WAS a bug turned temporary feature in my code, as it should not have sent me those texts just because of a reboot.

When I started trying to work out what was going on with the webcontrol it was very slow to non responsive to network requests. I added a new bit of code to text me any time the system booted after it acquired the correct time and fixed the wood needed bug. This way at least I had a text log of when it was rebooting vs needing wood. Also of course this helped figure out what was going on.

It took almost a week with some technical guidance from rossw. I had removed sensors down to one, changed network wires and power supplies, tried alternate methods to directly power it via 5v to the humidity sensor port. Eventually taking it in the house to a new environment were nothing but the network wire and power were connected.

Still rebooting, however much less.

Because of another project I was working on, I thought maybe I should take a quick look at the board under the lit magnifying glass while I had it out. This was the turning point, it seems that along the way I must have somehow bumped and loosened the C6 capacitor.

I reflowed the solder and since all has been stable plus the network response is normal speed.
I don’t know if this will help anyone else but I thought it may be worth writing up.

Trying to make power from alternative energy any which way I can.
Just to abuse what I make. (and run this site)

Offline tomw

  • Not as bad as you might think
  • Senior Moderator
  • Hero Member
  • *******
  • Posts: 739
  • Karma: +35/-0
  • hoplophobic people will fear my lifestyle
    • Zubbly's photos!
Re: Webcontrol 8 reboot problem solved.
« Reply #1 on: February 06, 2015, 01:22:31 am »
Just try to remember, it is a circuit board not an anvil!

Do NOT mistake me for any kind of "expert".

( ?° ?? ?°)


24 Trina 310 watt modules, SMA SunnyBoy 7.7 KW Grid Tie inverter.

I thought that they were angels, but much to my surprise, We climbed aboard their starship and headed for the skies

Offline oztules

  • Forum Advisors
  • Hero Member
  • ****
  • Posts: 1177
  • Karma: +105/-8
  • Village idiot
Re: Webcontrol 8 reboot problem solved.
« Reply #2 on: February 06, 2015, 04:23:16 pm »
Yes... sometimes it is not the software....... but mostly it is....

Good catch there.

Yesterday fixed a computer for some folks that kept turning itself off.... blew the fluff and dust out of the processor heat sink... now it's fine... some times the simple things too.


.....oztules
Flinders Island...... Australia